Skip to main content

Upgrade on hq16

Comments

2 comments

  • whitneyk
    Handi Quilter
    Great answers

    Paula,

    You can call HQ technical support and they can let you know if your machine is compatible. Some older machines don't work well with the new software in the Pro-Stitcher. 

    Best regards,

    Kristina Whitney

    Handi Quilter Studio Educator

    0
  • Paula Nelson

    Thank-you!

    0

Please sign in to leave a comment.

Powered by Zendesk